Enterprise Architect ENTERPRISE ARCHITECT

DBMS Driver Issues

 

Over the years there have been numerous versions of particular database drivers that cause compatiblity issues with Enterprise Architect and the Pro Cloud Server. In most cases Sparx Systems has no control over these issues as the drivers are produced by 3rd parties, therefore the easiest solution is simply to avoid them.

Therefore Sparx Systems advises that all versions listed below should be avoided.


MariaDB / MySQL

Version Date Found Observed Behavior
ODBC v8.0.26 Mar-2022 When attempting to make database updates the following error occurs:
"You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax"

Reason: Sparx Systems believe this is caused by the ODBC driver incorrectly determining the current permissions, we suggest v8.0.25 or v8.0.28 should be used instead.
ODBC v5.3.7 to v5.3.9 2018 When used in Pro Cloud Server (PCS) the PCS service could terminate unexpectedly.
see: MySQL bug report

Reason: The MySQL ODBC driver was compiled as single threaded, which caused issues in the multi-thread PCS.
ODBC v5.3.5 to 5.3.14 2018 When used in Pro Cloud Server (PCS) the PCS service could terminate unexpectedly.
An updated version of the MS Visual Studio redist are needed, check file:
  C:\Windows\SysWOW64\msvcr120.dll
the version should be 12.0.40649.5 anything earlier will cause issues, download link.

Reason: Sparx Systems believe the ODBC driver was going through a transitional period that used a different version of MS Visual Studio and the installer package wasn't updated to include the correct runtimes
ODBC v5.2.4 2013 Assorted errors - don't use
ODBC v5.2.2 2012 Assorted errors - don't use
ODBC v5.1.4 2008 Assorted errors - don't use
ODBC v5.1.1 2008 Assorted errors - don't use
ODBC v3.51.14 2007 Assorted errors - don't use


Oracle

No known issues.




MS SQL Server

No known issues.



PostgreSQL

Version Date Found Observed Behavior
ODBC v9.3.0300 Nov-2014 A customer reported the ODBC Administrator crashed when using the PostgreSQL 9.3.0300 driver, when they reverted back to v9.2 the problem no longer occurred.